Tech

What’s Old Is Still Relevant: Classic Atari Game Used in Classroom

Teacher Builds Atari 2600 Space Shuttle Simulator For 8th Graders:

Looking for a fun and immersive way to teach his 8th grade students about space, science instructor Chad Shumaker brought Activision’s 1984 sim Space Shuttle: A Journey into Space to his classroom…

This article brought a smile to my face for several reasons:

  • using video game technology to create an engaging educational experience
  • that you don’t need the latest and greatest games or hardware
  • the budget was dirt-cheap

and

  • the teacher took an awful game and made it fun (or less awful)

I’m curious as to how common it is for teachers to utilize old computer games  in the classroom. My guess is hardly, particularly as classic games such as Oregon Trail are now available on cellphone and Nintendo Wii.

(via GameSetWatch, The Times-Reporter)


Useful hidden OS X tips

There have been similar posts on other sites about this, but it never occurred to me that I would have any use of these tips until I had read rialvalue’s “Some little gems on OSX you might want to know”. For example, it’s sometimes useful to view hidden files from the Finder/Explorer window rather than mucking with comnandline stuff. It’s easy to view and set up hidden files on windows systems from the folder options. To do the same thing in OS X, open a Terminal window (in applications/utilities) and type the following:

defaults write com.apple.finder AppleShowAllFiles TRUE

You’ll need to restart the Finder to make this change go into effect, by either:

  • log out and back into your account
  • use the Force Quit dialogue (command+alt+esc and relaunch the Finder)
  • or type “killall Finder” in the Terminal window

The rialvalue article also mentions an applescript that allows you to open a terminal in the current Finder directory, but I find it easier to do the following:

  • open a Terminal window
  • type “cd” and then click-and-drag the Finder window onto the Terminal Window

Are there other hidden OS X tips that saves you a lot of time?

sources:

Some little gems on OSX you might want to know (via Flash Art of War)

Top 15 Terminal Commands for Hidden Mac OS X Settings


Who Watches the Watchmen: US policy had role in Google-China Hack

Nice CNN Op-Ed piece by Bruce Schneier on the role US policy had in the Chinese hacks of Google. He makes a strong case against backdoor access systems for law enforcement, i.e., that building a backdoor access system is just as likely to be abused as is it used for legal purposes:

The problem is that such control makes us all less safe. Whether the eavesdroppers are the good guys or the bad guys, these systems put us all at greater risk. Communications systems that have no inherent eavesdropping capabilities are more secure than systems with those capabilities built in.

U.S. enables Chinese hacking of Google (via Lifehacker)


FPS Bug in Adobe Media Encoder CS4

Adobe Media Encoder CS4 (AME) is a stand-alone app that comes with Flash CS4 and After Effects CS4. While it has the ability to do batch encoding and HD h264 .f4v’s (basically a .mp4 file in a flash wrapper), with its clunky interface, limited pre/post-processing options and odd bugs, you’re better off using full-featured encoders like Telestream’s Episode or Sorenson Squeeze. For those on a more limited budget though, AME  is usable. With that said, the most recent update to AME, 4.2.0.006 (11.10.2009) introduced a bug where you can no longer properly encode .flv’s at 15fps on OS X systems.

It’s a bug, Jim

AME 4.2 supposedly fixed deinterlacing if Max Render Quality was set for interlaced sources. Instead, the clip looks like it was possibly encoded at 15fps but is playing at 29.97, interpolating “missing frames.” I thought it was a playback issue, but I had encoded a sample clip earlier with AME 4.1 and using the same flv player, in this case VLC, you could still see a difference between the two clips. Here are two sample clips, one encoded with AME 4.1 and the other with AME 4.2. Take a look and you decide:

Video encoded using AME 4.1[flv:/movies/1-ame-4_1.flv 382 288]

Video encoded using AME 4.2[flv:/movies/2-ame-4_2.flv 382 288]

Although it’s not as obvious at this frame size, at 640 x 480, you can see how much sharper the image looks in the 4.1-encoded clip and the weird interpolating in the 4.2-encoded clip.

Solution and Workarounds

The current solution is to stick with 4.1. Already updated AME to 4.2? You have a couple of options:

Uninstall AME – Unfortunately, this is easier said than done: AME is a shared component, which means you have to uninstall every Adobe software that uses it. This is a royal pain for those with tweaked out preferences and/or using a Creative Suite. And don’t bother using AppCleaner; you’ll still be forced to re-install the “main” software (Flash, After Effects, Premiere Pro, etc.).

Use Leopard’s Time Machine to restore from an earlier point - This is the easiest solution, assuming you’ve been maintaining regular backups of your system. I recommend renaming the current Adobe Media Encoder CS 4 and then restoring to a version before 11/10/2009.

Copy AME 4.1 from another system - Fortunately, the AME app contents is self-contained within the Adobe Media Encoder CS 4 folder, so you can copy it from a another system that hasn’t updated to 4.2 yet. Rename or delete the 4.2 folder before you copy it over though, to make sure that you’re not mixing 4.1 and 4.2 stuff.

Another option is to encode straight from one of the “main” programs, in my case, After Effects. The disadvantages of this is that you no longer have access to to 2-pass VBR and longer encode times as the file has to also get rendered, unless you pre-render the clips and then set up the render queue to then encode them.

I must be the only one that’s seeing this bug because I couldn’t find any related posts either on the Adobe site or from a Google search, but I’ve posted this stuff in the hopes that it may help someone else and reduce their frustration with Adobe support. Note to Adobe:

  • include a bug report link on your support pages.
  • include support pages for the shared components like AME. It’s not worth posting on the forums if I don’t know where to post it in the first place and reasonably get feedback.

Has anyone seen this bug? Leave a comment.


  • Categories

  • Archives

  • Jarrah theme by Templates Next | Powered by WordPress